Skip to content

FCKeditorをローカルで動かすとエラーがでる

by haruma on 2010.07.01

WYSIWYエディターのFCKeditor(現在は後継のCKEditorに名称変更)の便利なプラグインにGoogleMaps  pluginがあり、それをローカル環境で使おうと、Firefox3からFCKeditorを使おうとすると、「Your browser security settings don’t allow FCKeditor to be opened from the local filesystem.」というエラーがでます。

Please open the about:config page and disable the “security.fileuri.strict_origin_policy” option; then load this page again.
と表示されるのですが、「open the about:config page」の意味がわからなかったので、検索すると、FirefoxではURLの入力欄に「about:config」と入力すると設定画面に移動するのでした。知りませんでした。

設定画面にはいったら、エラーメッセージ通り、「security.fileuri.strict_origin_policy」をダブルクリックして値をfalseに変更すると、エディターは動きました。

というか、この記事のエラーにGoogleMaps  pluginが影響しているわけでありません。ただ、便利なプラグインを紹介したかっただけでした。。
GoogleMapsuプラグインhttp://martinezdelizarrondo.com/googlemaps/
下のほうにデモもあります。

From → WEB制作

No comments yet

Leave a Reply

Note: XHTML is allowed. Your email address will never be published.

Subscribe to this comment feed via RSS